Jump to content
Sign in to follow this  
MVEsperanza

.X Problems

Recommended Posts

Hello Guys I have the following 3D Software Programs:
 
-Visual Enterprise Author (Deep Exploration)
-3Ds Max 2013
-Maya 2014
-Sketch-Up Pro
 
Im new to Maya and have a model i want to convert to VSF (.x) but i dont know how any help would be great. DE works but the Textures mess up in VSF from that converter im hoping that it wont happen with Maya Conversion.

 

So i figured out how to convert  it but the problem is the same this is what i am experiencing..
 
The Text on the Sauser reads: USS Kelvin and NCC-0514 but there is for some reason a problem in the middle of the black letters where it becomes transparent when only the white part of the picture is supposed to be transparent which it is but the black is supposed to be there
 
Second Problem, random Hole in the Hull I cant fix it i dont know why
 
4tueq9.jpg
 
2wdq0ie.jpg

 

 

Share this post


Link to post
Share on other sites

I been waiting for you :)

 

Ok now that your here I can help you but I cant over at the other place.

First was that model a ( .OBJ ) file to start with, I ask because then faces that are missing reminds me of a obj file that has been turned into a 3DS, if so then you have some work to do on rebuilding them faces or find a program that will do obj to 3DS without things like that happen.

 

Now for the X file;

 

I see you have 3D Max 2013, do you also have 3D max 2012 or a earlyer one like 10 or 9?

Pandasoft makes a X exporter for 3D max 2012 and back, I use it on my 3D max9 and its very good for VSF.

http://www.andytather.co.uk/panda/directxmax_downloads.aspx

 

As for Deep Exploration, I have this also and its also very good and will do a nice X file for VSF but it needs to be setup right so give me about 1 hour and I will post you some screens on the setup that I use for this, ok.

 

Also you should be using BMP or JPG 1024 by 1024 for your texture JPG runs the best for VSF and 1024 by 1024

works the best for most vid cards in VSF. 

 

OK I be back with them screen shots for you.

 

Deutschmark

Share this post


Link to post
Share on other sites

Ok thanks No the file is Maya Originally.

 

I have a .x exporter for 3Ds Max 2013 i dont have 2012 or earlier :( 

 

the format currently of the translucent files is PNG so that may be the issue but still the will the black show up?

Share this post


Link to post
Share on other sites

here is the DE export tabs and my settings and they work fine with 3DS to X.

 

DE1.jpg

 

DE2.jpg

DE3.jpg

DE4.jpg

DE5.jpg

 

 

Ok, is the black text right on the texture for the ship or is it another texture? 

Cant tell from the photos.

 

Deutschmark

 

PS; its getting late here so am off for the night soon, so just post if you need to know more or tell me something and I will see it tomorrow when I get up and post back to you.

Share this post


Link to post
Share on other sites

Ok then VSF will not handle a part of a texture being translucent and the rest not being translucent, in

VSF it has to be all translucent or not, much like a fast prop or glass, so it would be best if you could put

them numbers right on the texture they are going over, or just live with what you have now. 

 

Deutschmark

 

PS; but now am off to bed for the night.

Share this post


Link to post
Share on other sites

Look to see in your 3D program if they are missing, if they are not then its in your exporting and

I don't know Maya exporting so you will need to play with that and that exporter you have for Max 

2013 if its not a Pandasoft one then cant help there, try this make a 3DS of the model put it into DE

and have a look to see if there are any missing faces if not then make a X file out of DE and see

what you get.

 

Deutschmark

 

PS; I just looked in before I turned off my PC that's what I posted this.

Share this post


Link to post
Share on other sites

Hi John and MV,

 

the best way for convert max files to x files is Pandasoft's Plugin (unfortunately only for Max2012 or older).

 

The hole in the mesh looks like a flipped poly. If the poly deleted, you can add a bridge between the edges and create a new poly in this part.

 

The model looks like the Kelvin model from Tobias Richter. If I remember the Kelvin uses multi-textures. I have tryed to work with multi-textures in VSF

I think they work not correct in VSF. Either you change the material properties in the material editor or you rework the textures. ;)

 

Regards

Marko

 

.

Share this post


Link to post
Share on other sites

when you look at the model in your 3D program are them faces there?

If not then they may be flipped and your seeing the back face and you need

to flip them back, but if they are not there then you need to rebuild them.

 

Deutschmark

Share this post


Link to post
Share on other sites

Ok Found Out the Problems

 

Arrialp had informed me the reason the texture is translucent is because i had a "_" in the name of the texture all though when i fixed it the background matched the color of the Kelvins Plates but not plated.

 

Ok I also found the little section there is inverted so i ineed to revese that fase but i cant flip it with out flipping the whole thing

Share this post


Link to post
Share on other sites

Yup Thanks Guys for all your help!

 

Actually Im wondering now how to make the lights appear in VSF the ship already glows on parts i need it to glow but there glow the lights are supposed give off sor to say illuminate the Hull Name and Number How do i do those?

Share this post


Link to post
Share on other sites

Good to hear look forward to your model.

 

 

This was put in update version 2.5.2 the latest one.

 

Added vehicle tags lightsl, lightsr, lightsm, lightst, which glow on vehicle when light is on.

 

Like this;

vehicle3.jpg

 

 

Deutschmark

Share this post


Link to post
Share on other sites

like this as a example;

 

lightslwhite        [light_name]
0.009                 [light_scale]
-1.80                  [light_x]
2.62                   [light_y]
-13.95                [light_z]

 

The tag name that will make the white light glow is ( lightsl ) in this example. 

 

  

Deutschmark

Share this post


Link to post
Share on other sites

Lol sounds complicated can u make a little tutorial if u have time?

Thanks so much for all your help so far I truly appreciate it! I'm off to bed. Have good day/night! :)

Sincerely,

Devin Rodrigues

Share this post


Link to post
Share on other sites

Ok we try;

 

the colors names in VSF are;

 

Red

Green

White

Yello = yellow

Blue

 

the tag names in VSF are;

 

Strobe - blinking light

Beam - light beam with cone

Brakes - car red brake lights

Blinker - car orange blinker

Reverse - car white reverse

Fore - forward

Back - backwards

Omni - omni directional

Flat - forward or aft flat

 

 So if I want a blinking red light I would put this in the lights name;

 

strobered        [light_name]

 

This is for the scale size of the light;

 

0.009                 [light_scale]

 

This is for the X,Y,Z of the light on your model;

 

-1.80                  [light_x]
2.62                   [light_y]
-13.95                [light_z]

 

 

This is a example of one of my light cfg's for my F-15;

 

6  [lights_num]

 

OmniRed         [light_name]
0.009  [light_scale]
-6.36  [light_x]
-0.52  [light_y]
-9.65  [light_z]

 

OmniWhite        [light_name]
0.009  [light_scale]
-1.80  [light_x]
2.62  [light_y]
-13.95  [light_z]

 

OmniRed         [light_name]
0.009  [light_scale]
-1.80  [light_x]
2.47  [light_y]
-13.95  [light_z]

 

OmniGreen        [light_name]
0.009  [light_scale]
6.36  [light_x]
-0.52  [light_y]
-9.65  [light_z]

 

OmniWhite        [light_name]
0.009  [light_scale]
1.80  [light_x]
2.62  [light_y]
-13.95  [light_z]

 

OmniGreen        [light_name]
0.009  [light_scale]
1.80  [light_x]
2.47  [light_y]
-13.95  [light_z]

/// F15

 

---------------------------------------------------------------------

These here are parts on a model;

 

lightsl = glow on when light is on

lightsr = glow on when light is on

lightsm = glow on when light is on

lightst = glow on when light is on

 

So like if you have 5 parts that you wont them to be glowing lights on the right side lets say

you would make them all one group and give them the part name lightsr and when the lights

are turned on they will glow.

 

----------------------------------------------------------------

 

Hope that helps.

 

Deutschmark

Share this post


Link to post
Share on other sites

I just come to know I made a boo boo :huh:

 

These here are parts on a model;

 

lightsl = glow on when light is on

lightsr = glow on when light is on

lightsm = glow on when light is on

lightst = glow on when light is on

 

So like if you have 5 parts that you wont them to be glowing lights on the right side lets say

you would make them all one group and give them the part name lightsr and when the lights

are turned on they will glow.

 

Sorry about that, but I never used these as they are new and I have not done anything

new that would need these.

 

Deutschmark

 

PS; I fixed above as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...